AWS has restored the affected systems that caused the outage in the US-EAST-1 region. All ID DataWeb services are operating normally. We are marking this incident as resolved.
Posted Oct 20, 2025 - 18:30 EDT
Update
Our Application Performance Monitoring tools indicate that ID Dataweb systems remain fully operational, in spite of the ongoing AWS issues, since roughly 9:30am ET. We will keep this incident in "monitoring" state until AWS fully closes the incident on their side.
Posted Oct 20, 2025 - 16:11 EDT
Update
All systems have appeared operational since ~9:30am ET. We are continue to closely monitor, as the broader AWS outage remains ongoing. We will continue to provide live updates here until all 3rd party systems are restored.
Posted Oct 20, 2025 - 12:13 EDT
Monitoring
Our DevOps team has identified and resolved an issue relating to 3rd party services affected by the current AWS Outage, and we are seeing traffic return to normal. We are running regression and monitoring closely. Customers should see traffic returning to normal. More updates to come.
Posted Oct 20, 2025 - 09:43 EDT
Investigating
We are experiencing issues relating to the current AWS outage. As of earlier this morning, ID Dataweb successfully failed over to US EAST 2, which mitigated the issue. Now - we are seeing increased latency, likely caused by 3rd party services being affected by the same issues. We are investigating, and will post updates in real time.