Verification is currently underway for the maintenance items.
Posted Nov 22, 2025 - 22:21 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 22, 2025 - 22:00 EST
Scheduled
We will be performing upgrades to our US-East-1 cluster on 11/22/25 starting at 10PM ET and lasting for no more than 3 hours. No downtime or impact is expected; there will be a separate upgrade window for our EU-West-1 cluster on 11/15/25.
Posted Oct 28, 2025 - 16:11 EDT
This scheduled maintenance affected: Platform (AXN, Admin, Attribute Providers).