This incident has been resolved and an RCA will be provided as soon as possible.
Posted Mar 20, 2025 - 15:41 EDT
Monitoring
Our team has fully resolved the related infrastructure issues and all services are fully operational for all customers at this time. We will continue to monitor performance and follow-up directly with a RCA.
Incident Start: 03/20/2025, 11:50 AM EST Incident End: 03/20/2025, 01:30 PM EST Incident Duration: 1h 40m
You can check this page (status.iddataweb.com) regularly or subscribe to its updates per your preference. Please contact support@iddataweb.com with any additional questions or concerns.
Posted Mar 20, 2025 - 13:37 EDT
Identified
An issue with one of our Production clusters in US-East-1 (AWS) resulted in a partial failover to US-East-2; our team has identified the issue with the failover instance and is working on the fix. Services remain unavailable to API customers and degraded for Gateway customers; access to the admin console also remains degraded at this time.
We will provide updates within every hour until resolution. We understand the impact of this incident and appreciate your patience. Please contact support@iddataweb.com with any questions or concerns.
Posted Mar 20, 2025 - 13:29 EDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2025 - 12:38 EDT
Update
Service has been restored for Gateway customers and remains unavailable for API customers; we are actively resolving the issue and scaling back up relevant infrastructure.
Posted Mar 20, 2025 - 12:33 EDT
Update
Service has been partially restored and the team is monitoring the relevant infrastructure changes.
Posted Mar 20, 2025 - 12:21 EDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2025 - 12:09 EDT
Investigating
We are rapidly investigating an infrastructure issue affecting our PreProduction and Production environments and will provide updates shortly. The majority of traffic is currently believed to be affected including access to the admin console.
Posted Mar 20, 2025 - 12:06 EDT
This incident affected: Platform (AXN, Admin, Attribute Providers) and Integrations (API, Gateway).