KBA - Elevated Errors

Incident Report for ID Dataweb

Resolved

All KBA services have returned to normal
Posted Jul 14, 2026 - 15:01 EDT

Update

We are seeing signs of recovery from our internal monitoring tools. We will update status once we confirm full recovery
Posted Jul 14, 2026 - 14:46 EDT

Monitoring

We are observing elevated error rates on KBA services in production. We are monitoring this closely and will update the status of this issue as it becomes available.
Posted Jul 14, 2026 - 11:58 EDT
This incident affected: Platform (Attribute Providers).