Update - The BiogovID service has been restored, per https://status.incode.com/. We are observing all BiogovID traffic returning to a normal state. We will provide an RCA from the vendor when available.
Posted Oct 20, 2025 - 16:05 EDT
Identified
Our primary BiogovID vendor is currently experiencing performance issues relating to the ongoing AWS Outage, leading to transaction failures. We are closely monitoring the situation. Status updates for GovID users can be followed here: https://status.incode.com/
Posted Oct 20, 2025 - 14:25 EDT
This incident affected: Platform (Attribute Providers).