BiogovID Issues

Incident Report for ID Dataweb

Resolved

All systems have remained operational since the last update. We will continue to actively monitor throughout the day.
Posted Nov 18, 2025 - 15:24 EST

Monitoring

Cloudflare has deployed a solution, which has addressed the issues with our GovID vendor. We are continuing to monitor closely.
Posted Nov 18, 2025 - 10:10 EST

Identified

Our GovID verification partner is currently experiencing issues due to the ongoing Cloudflare outage. We are in touch with the vendor, and will update as we get more information.

More information can be found at the following links:
- https://www.cloudflarestatus.com/
- https://status.incode.com/
Posted Nov 18, 2025 - 09:15 EST
This incident affected: Platform (Attribute Providers).