Latency on PII Validation Services

Incident Report for ID Dataweb

Resolved

Experian remains fully operational. The team will continue to actively monitor throughout the day.
Posted Nov 13, 2025 - 09:54 EST

Monitoring

Experian services have returned to normal performance levels. We will continue to actively monitor to ensure no further impact.
Posted Nov 13, 2025 - 09:01 EST

Investigating

We are observing increased latency and timeouts on Experian services. We are in touch with the vendor, and will provide updates in real time.
Posted Nov 13, 2025 - 08:21 EST
This incident affected: Platform (Attribute Providers).