We are observing traffic returning to normal levels within the last hour. We are following up with 3rd party providers to get more details into the issue. Once more information is obtained, ID Dataweb will provide an RCA to affected parties.
Posted Nov 03, 2025 - 13:09 EST
Investigating
We are investigating increased latency on the ID Dataweb system. We are observing 3rd party API calls failing, including Experian. Our team is evaluating, and will provide updates in real time.
Posted Nov 03, 2025 - 11:44 EST
This incident affected: Platform (Attribute Providers).